> - _memsize = 65227 # 65227 read from dump ?
> - _block_lengths = [10, 65555] # ????? Not sure why this works to match _memsize
> + _memsize = 65227 # 65227 read from dump
> + _block_lengths = [10, 65217]
I was going to complain that you just tweaked the comment on the memsize line unnecessarily, but... are you removing that "?" because you really weren't sure before and now you've got it figured out?
And, are you saying that you're confident now that 65217 is the right value for the last block after the yaesu_clone change? Like, 65555 was the magic value that worked for your own timing, with the zero-block reads you were getting before?
I assume this is confirmed to fix the problem the other person was having?
If all the above is correct, then...cool :)
> diff -r 96bc56916c95 -r 9e3b0ff76308 chirp/drivers/yaesu_clone.py
> --- a/chirp/drivers/yaesu_clone.py Tue Mar 20 21:38:07 2018 -0400
> +++ b/chirp/drivers/yaesu_clone.py Fri Mar 23 17:52:01 2018 +0000
So, this code hasn't changed in so long I'm a little nervous about changing it. Is there anyone else on the dev list here that can give it a sniff test? I'm not sure I have any yaesu radios I can easily test with, but I'll look.
If not, we'll just have to merge it and warn the users list to test it ASAP.
--Dan
_______________________________________________
chirp_devel mailing list
chirp_devel@intrepid.danplanet.com
http://intrepid.danplanet.com/mailman/listinfo/chirp_devel
Developer docs: http://chirp.danplanet.com/projects/chirp/wiki/Developers